(TK) Konfiguracja tuneli IPv6*

Wstęp teoretyczny

Dynamiczny tunel GRE IPv6 over IPv4 (6to4)

  • Dynamicznie nawiązywanie tuneli GRE (IPv6 over IPv4), umożliwia nawiązanie połączenia point-to-multipoint, traktowanego jako sieci NBMA (Virtual Nonbroadcast Multiaccess)(Zwykłe tunele GRE nawiązuje połączenie point-to-point).
  • Tunele GRE 6to4 charakteryzują następujące cechy:
    • Docelowy adres IPv4 sąsiedniego urządzenia brzegowego dla inne strefy IPv6, jest pozyskiwany z adresu IPv6, zapisanego w formacie 2002:adresIPv4urządzeniabrzegowego::/48.
    • Podstawowa topologia składa się z wielu stref IPv6, z których każda podłączona jest przynajmniej jednym interfejsem do współdzielonej sieci IPv4.
    • Każdy z ruterów brzegowych powinien posiadać globalnie unikalny adres IPv4 umożliwiający stworzenie globalnie unikalnego adresu IPv6 6to4. Dzięki czemu możliwe staje się stworzenie mapowania adresów IPv4 jak i IPv6 za pomocą DNS-u.
Ruter brzegowy musi wspierać zarówno protokół IPv4 jak i IPv6.

Konfiguracja tuneli IPv6

Konfiguracja tunelu IPv6 over IPv4

Konfiguracja tunelu

(config)# ipv6 unicast-routing

Aktywuje funkcję routingu dla protokołu IPv6.

(config)# interface interfejs

Przechodzi do poziomu konfiguracji interfejsu sieciowego (Źródłowego interfejsu IPv4 względem tunelu IPv6).

(config-if)# ip address adres-IPv4

Przypisuje adres IPv4, do konfigurowanego interfejsu sieciowego.

(config-if)# interface tunnel 0-2147483647(tunel-ID)

Przechodzi do poziomu konfiguracji wirtualnego interfejsu sieciowego.

(config-if)# ipv6 address {adres-IPv6 / enable}

Przypisuje adres IPv6 do konfigurowanego tunelu GRE.

(config-if)# tunnel source {adres-IPv4 / interfejs}

Określa źródłowy interfejs wyjściowy / IPv4 interfejsu wyjściowego.

(config-if)# tunnel destination adres-IPv4

Określa docelowy adres IPv4 tunelu wirtualnego.

(config-if)# tunnel mode ipv6ip

Określa tryb pracy tunelu wirtualnego na IPv4 over IPv4.

Konfiguracja trasy statycznej

(config)# ipv6 route adres-IPv6 tunnel 0-2147483647(tunel-ID)

Definiuje trasę statyczną dla konfigurowanego tunelu wirtualnego.

Konfiguracja tunelu 6to4

Konfiguracja tunelu GRE

(config)# ipv6 unicast-routing

Aktywuje funkcję routingu dla protokołu IPv6.

(config)# interface interfejs

Przechodzi do poziomu konfiguracji interfejsu sieciowego (Źródłowego interfejsu IPv4 względem tunelu IPv6).

(config-if)# ip address adres-IPv4

Przypisuje adres IPv4, do konfigurowanego interfejsu sieciowego.

(config-if)# interface tunnel 0-2147483647(tunel-ID)

Tworzy nowy interfejs wirtualny (Tunel GRE).

(config-if)# tunnel mode ipv6ip 6to4

Zmienia tryb pracy tunelu GRE na „Automatic 6to4”. Komenda ta musi być wydana jako pierwsza, w trybie konfiguracji tunelu wirtualnego.

(config-if)# ipv6 address 2002:XXXX:XXXX::/128

Przypisuje adres IPv6 do konfigurowanego tunelu GRE (XXXX:XXXX odnosi się do adresu IPv4, interfejsu fizycznego (Source), zapisanego w postaci heksadecymalnej.

(config-if)# tunnel source {adres-IPv4 / interfejs}

Określa źródłowy interfejs wyjściowy / IPv4 interfejsu wyjściowego.

Konfiguracja sieci LAN

(config)# interface interfejs

Przechodzi do poziomu konfiguracji interfejsu sieciowego.

(config-if)# ip address prefix-IPv6/prefix-length

Przypisuje adres IPv6, do konfigurowanego interfejsu sieciowego.

(config-if)# ipv6 route sieć-IPv6(LAN) 2002:XXXX:XXXX::(Adres tunelu, następnego przeskoku)

Tworzy statyczną trasę routingu.
Tunel automatic 6to4 nie jest kompatybilny z dynamicznymi protokołami routingu.
Wszystkie adresy IPv6 znajdujące się w jednej lokalizacji muszą posiadać część wspólną, odpowiadającą adresowi IPv4.

Przykładowa konfiguracja tunelu 6to4

  • W poniższym przykładzie konfiguracji automatycznego tunelu 6to4. Wszystkie adresy IPv6 skonfigurowane na podanych urządzeniach, odpowiadają lokalnym adresom IPv4, będącym siecią tranzytową dla nawiązywanego tunelu. Działają one tym samym jako część identyfikująca dany odział zdalny. W sytuacji nawiązywania tunelu GRE pomiędzy oddziałami, ruter odzyskuje adres IPv4 z adresu IPv6, a następnie wykorzystuje go jako adres docelowy dla nawiązywanego tunelu.

Konfiguracja pierwszego oddziału zdalnego

Site1(config)# ipv6 unicast-routing

Site1(config)# interface gigabitethernet 0/0

Site1(config-if)# ip address 10.20.30.1 255.255.255.0

Konfiguracja współdzielonej sieci IPv4.

Site1(config-if)# interface tunnel 1

Site1(config-if)# ipv6 address 2002:0A14:1E01::1/64

Site1(config-if)# tunnel source gigabitethernet 0/0

Site1(config-if)# tunnel mode ipv6ip 6to4

Konfiguracja tunelu GRE z adresacją IPv6 (Adres zawiera część wspólną, przeliczoną z systemu dziesiętnego na system szesnastkowy, na podstawie adresu IPv4. (0A14:1E01 / 10 = 0A / 20 = 14 / 30 = 1E / 1 = 01)).

Site1(config-if)# interface loopback 99

Site1(config-if)# ip address 2002:0A14:1E01:99::1/64

Konfiguracja dodatkowego interfejsu sieciowego z adresem IPv6, również posiadającym cześć wspólną.

Site1(config-if)# ipv6 route 2002::/16 tunnel 1

Konfiguracja trasy statycznej dla routingu IPv6.

Konfiguracja drugiego oddziału zdalnego

Site2(config)# ipv6 unicast-routing

Site2(config)# interface gigabitethernet 0/0

Site2(config-if)# ip address 10.20.30.2 255.255.255.0

Konfiguracja współdzielonej sieci IPv4.

Site2(config-if)# interface tunnel 1

Site2(config-if)# ipv6 address 2002:0A14:1E02::1/64

Site2(config-if)# tunnel source gigabitethernet 0/0

Site2(config-if)# tunnel mode ipv6ip 6to4

Konfiguracja tunelu GRE z adresacją IPv6, odpowiadającą lokalnemu adresowi IPv4.

Site2(config-if)# interface loopback 99

Site2(config-if)# ip address 2002:0A14:1E02:99::1/64

Konfiguracja dodatkowego interfejsu sieciowego z adresem IPv6, również posiadającym cześć wspólną.

Site2(config-if)# ipv6 route 2002::/16 tunnel 1

Konfiguracja trasy statycznej dla routingu IPv6.

Pozostałe tematy związane z konfiguracją protokołu IPv6

Przydzielanie adresów IPv6

Protokół NAT względem protokołu IPv6

PDFPRINT

Robert T Kucharski

Cisco Network Engineer in GPW.

Dodaj komentarz