(K) Podstawowa konfiguracja protokołu OSPF**

Wstęp teoretyczny do konfiguracji protokołu OSPF

  1. Pierwszym krokiem umożliwiającym konfigurację dynamicznego protokołu routingu, jest stworzenie nowej instancji OSPF za pomocą komendy [router ospf Proces-ID] wydanej w trybie konfiguracji systemu IOS. (W przypadku konfiguracji przełącznika warstwy trzeciej wpierw należy włączyć funkcjonalność routingu za pomocą komendy [ip routing] wydanej w trybie konfiguracji systemu IOS).
  2. Po stworzeniu nowej instancja protokołu OSPF, należy określić jakie sieci będą przez nią rozgłaszane za pomocą komendy [network sieć dzika-maska area ID-strefy] bądź komendy [ip ospf Proces-ID area ID-strefy] wydanej w trybie konfiguracji określonego interfejsu sieciowego. Po zastosowaniu nie mniejszej komendy router rozpocznie:
    1. Wysyłanie wiadomości powitalnych na określonych przez komendę [network] interfejsach.
    2. Proces dodawania sieci przyległych, określonych przez komendę [network] do bazy topologii.
  3. W celu zlokalizowania interfejsów, na których ma być aktywowany protokół OSPF, router porównuje sieć zawartą w komendzie [network sieć dzika-maska area ID-strefy] z adresami skonfigurowanymi na interfejsach urządzenia. Korzystając przy tym z logiki postępowania list ACL.
  4. Bez względu na kolejność wpisywania komend [network], router przetrzymuje wpisane sieci w konfiguracji urządzenia, zaczynając od tej najbardziej szczegółowej. Np. użycie komendy [network 10.1.12.2 0.0.0.0 area 0] wraz z komendą [network 10.1.0.0 0.0.255.255 area 1] spowoduje, że interfejs z adresem IP 10.1.12.2 będzie należał do strefy
  5. Inną metodą umożliwiającą dodanie sieci do protokołu OSPF jest komenda [ip ospf ASN area ID-strefy] wydana w trybie konfiguracji określonego interfejsu sieciowego.

Konfiguracja protokołu OSPF

Rozgłaszanie sieci

Rozgłaszanie sieci z poziomu konfiguracji protokołu OSPF

(config)# router ospf Proces-ID

Przechodzi do poziomu konfiguracji protokołu OSPF.

(config-router)# router-id RID(0-255.0-255.0-255.0-255)

Określa numer ID (RID) konfigurowanego rutera. Skonfigurowanie statycznej wartości RID, w momencie gdy ruter posiada już aktywne relacje sąsiedztwa, wymaga resetu aktywnych relacji za pomocą komendy [clear ip ospf process].

(config-router)# network sieć dzika-maska area ID-strefy

Określa sieć, na podstawie której, ruter decyduje na jakich interfejsach będą rozgłaszane wiadomości „hello” protokołu OSPF. Przykładowa sieć 100.1.1.0/24 skonfigurowana na interfejsie sieciowym za pomocą komendy [ip address 100.1.1.4 255.255.255.0], może być dodana do procesu OSPF w jeden z poniższych sposobów:
* network 0.0.0.0 0.0.0.0 a 0
* network 100.0.0.0 0.255.255.255 a 0
* network 100.1.1.0 0.0.0.255 a 0
* network 100.1.1.4 0.0.0.0 a 0

# show ip ospf neighbor

Wyświetla listę aktywnych sąsiadów protokołu OSPF.

# show ip ospf interface {brief / interfejs}

Wyświetla interfejsy sieciowe, aktywne względem protokołu OSPF.

Rozgłaszanie sieci z poziomu konfiguracji interfejsu sieciowego

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip ospf Proces-ID area ID-strefy

Włącza funkcje rozgłaszania wiadomości „hello” protokołu OSPF na danym interfejsie (Jest to nowsza wersja komendy [network]).

# show ip ospf interface {brief / interfejs}

Wyświetla interfejsy sieciowe, aktywne względem protokołu OSPF.

Konfiguracja opcjonalnych ustawień protokołu OSPF

Zaawansowana konfiguracja OSPF

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip ospf demand-circuit

Zaprzestaje wysyłania wiadomości powitalnych (Hello) na konfigurowanym interfejsie sieciowym. Funkcja ta jest stosowana na połączeniach WAN, dla których płatność jest uzależniona od czasu wykorzystania łącza.

(config-if)# ip ospf flow-reduction

Blokuje licznik Age, względem rozgłaszanych struktur LSA. Komenda [show ip ospf database] wyświetla pełną bazę LSDB (Struktury LSA z zablokowanym licznikiem będą posiadały oznaczenie [(DNA)]).

Manipulowanie domyślnymi wartościami czasów OSPF

# Teoria dotycząca czasów protokołu OSPF została opisana w artykule: Wiadomości protokołu OSPF.

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip ospf hello-interval 1-65535(10)(sekund)

Zmienia domyślną wartość czasu „Hello-timer” (Ponadto komenda ta automatycznie zmieni wartość czasu „Dead-timer” do czterokrotności nowo skonfigurowanej wartości „Hello-timer”).

(config-if)# ip ospf dead-interval 1-65535(40)(sekund)

Zmienia domyślną wartość czasu „Dead-timer” (Zgodnie z zaleceniami Cisco wartość ta powinna stanowić czterokrotność czasu „Hello-timer”).

(config-if)# ip ospf retransmit-interval 1-65535(5)(sekund)

Zmienia domyślną wartość czasu „retransmit-interval” (Jest to wartość wykorzystywana w celu retransmisji wiadomości DBD. W sytuacji w której ruter nie otrzyma wiadomości Acknowledgment potwierdzającej otrzymanie wiadomości DBD od swojego sąsiada, w przeciągu określonego czasu „retransmit-interval”. Ponowi próbę przekazania wiadomości DBD).

(config-if)# ip ospf dead-interval minimal hello-multiplier 3-20(ilość wiadomości na sekundę)

Jednocześnie zmienia domyślną wartość czasu „Hello-timer” oraz czasu „Dead-timer”.

# show ip ospf [ASN] interface [interfejs] | include Timer|line

Wyświetla informacje na temat skonfigurowanych czasów protokołu OSPF, względem określonego interfejsu bądź wszystkich interfejsów sieciowych.

Konfiguracja funkcji Load-balance

(config)# router ospf Proces-ID

Przechodzi do poziomu konfiguracji protokołu OSPF.

(config-router)# maximum-paths 1-32(4)

W przypadku istnienia wielu ścieżek o takim samym koszcie, prowadzących do tej samej sieci. Protokół OSPF umożliwia funkcję równomiernego rozprowadzenia ruch pomiędzy czterema drogami. Powyższa komenda umożliwią zmniejszenie bądź zwiększenie tej wartości.

# show ip protocols

Wyświetla konfiguracje protokołu OSPF, w tym skonfigurowaną wartość „maximum-paths”.

Elekcja rutera pełniącego rolę DR oraz BDR

# Teoria dotycząca elekcji urządzeń DR / BDR została opisana w artykule: Nawiązywanie relacji sąsiedztwa.

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip ospf priority 0-255(1)

Określa priorytet rutera biorącego udział elekcji roli DR/BDR. W przypadku skonfigurowania wartości „0” ruter nigdy nie zostanie wybrany DR-em lub BDR-em.

# show ip ospf interface [interfejs] | include Priority

Wyświetla informacje na temat skonfigurowanej wartości priorytetu OSPF, względem określonego interfejsu bądź wszystkich interfejsów sieciowych.

Wyłączenie procesu OSPF

(config)# router ospf Proces-ID

Przechodzi do poziomu konfiguracji protokołu OSPF.

(config-router)# shutdown

Włącza proces OSPF powodując tym samym:
* Zamknięcie wszystkich relacji sąsiedztwa.
* Wstrzymanie procesu nawiązywania nowych relacji sąsiedztwa.
* Zatrzymanie procesu wysyłania wiadomości Hello.
wyłączenie procesu OSPF nie usuwa konfiguracji danego procesu z pliku konfiguracyjnego urządzenia.

Wiadomości systemowe (Logging) protokołu OSPF

(config)# router ospf Proces-ID

Przechodzi do poziomu konfiguracji protokołu OSPF.

(config-router)# log-adjacency-changes detail

Wysyła wiadomość systemową w przypadku zmiany statusu relacji sąsiedztwa.

Zmiana domyślnej wartość AD (Administrative Distance)

(config)# router ospf Proces-ID

Przechodzi do poziomu konfiguracji protokołu OSPF.

(config-router)# distance 1-255(110)

Zmienia domyślną wartość AD, względem konfigurowanej instancji protokołu OSPF.

(config-router)# distance ospf external 1-255(110)

Zmienia domyślną wartość AD względem tras zewnętrznych (External), konfigurowanego protokołu OSPF.

(config-router)# distance ospf intra-area 1-255(110)

Zmienia domyślną wartość AD względem tras wewnętrznych (Intra), konfigurowanego protokołu OSPF.

(config-router)# distance ospf inter-area 1-255(110)

Zmienia domyślną wartość AD względem tras między-strefowych (Inter), konfigurowanego protokołu OSPF.

# show ip protocols

Wyświetla konfiguracje protokołu OSPF, w tym skonfigurowaną wartość AD.

Pozostałe tematy związane z konfiguracją protokołu OSPF

Struktury LSA

OSPFv3

PDFPRINT

Robert T Kucharski

Cisco Network Engineer in GPW.

Dodaj komentarz