(K) Konfiguracja funkcji VRF**

Konfiguracja wirtualizacji VRF

Funkcję VRF można skonfigurować za pomocą komendy [ip vrf nazwa-VRF] jak i komendy [vrf definition nazwa-EVN], z tymże pierwsza z opcji wspiera jedynie protokół IPv4, natomiast druga wspiera zarówno protokół IPv4 jak i protokół IPv6.

Konfiguracja funkcji VRF

(config)# ip vrf nazwa-VRF

Tworzy nową instancję wirtualizacji VRF.

(config-vrf)# rd ASN:liczba

Określa parametry funkcji VRF Distinguisher.

(config-vrf)# descryption opis

Definiuje opis nowej instancji VFR.

(config-vrf)# interface interfejs[.pod-interfejs]

Przechodzi do poziomu konfiguracji określonego interfejsu / pod-interfejsu sieciowego.

(config-if)# encapsulation dot1Q 2-4094(vlan-ID)*

Określa metodę enkapsulacji sieci VLAN. W przypadku konfiguracji pod-interfejsu.

(config-if)# ip vrf forwarding nazwa-VRF / vrf forwarding nazwa-VRF

Przypisuje konfigurowany interfejs / pod-interfejs do określonej instancji VRF.
Aktywacja wirtualizacji VRF na określonym interfejsie sieciowym, spowoduje usunięcie skonfigurowanego wcześniej adresu IP.

(config-if)# router ospf ASN vrf nazwa-VRF

Przechodzi do poziomu konfiguracji protokołu OSPF względem określonej instancji funkcji VRF.

# show ip vfr

Wyświetla wszystkie instancje VRF, skonfigurowane na danym urządzeniu.

Konfiguracja protokołu EIGRP pod kontem funkcji VRF

(config)# router eigrp [ASN]

Przechodzi do poziomu konfiguracji protokołu EIGRP.

(config-if)# address-family ipv4 vrf nazwa-VRF autonomous-system ASN

Przypisuje konfigurowaną instancję protokołu EIGRP do wskazanej instancji funkcji VRF.

Konfiguracja wirtualizacji EVN

Definicja VRF

(config)# vrf definition nazwa-EVN

Tworzy nową instancję wirtualizacji EVN.

(config-vrf)# address-family {ipv4 / ipv6}

Określa protokół warstwy trzeciej, jaki będzie wykorzystywany przez konfigurowaną instancję VRF. Jedna instancja VRF może wykorzystywać dwie różne rodziny adresów IP jednocześnie.

(config-vrf)# vnet tag 2-4094(vlan-ID)

Określa wartość ID (Sieć VLAN) przypisaną do konfigurowanej instancji EVN.

(config-vrf)# descryption opis

Definiuje opis nowej instancji EVN.

# show ip vfr

Wyświetla wszystkie instancje VRF, skonfigurowane na danym urządzeniu.

Przypisanie interfejsu do jednej instancji VRF

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip address adres-IP

Przypisuje adres IP do konfigurowanego interfejsu sieciowego.

(config-if)# vrf forwarding nazwa-EVN

Przypisuje konfigurowany interfejs sieciowy do określonej instancji EVN.
Aktywacja wirtualizacji EVN na określonym interfejsie sieciowym, spowoduje usunięcie skonfigurowanego wcześniej adresu IP.

Przypisanie interfejsu do wielu instancji VRF (EVN)

(config)# interface interfejs

Przechodzi do poziomu konfiguracji określonego interfejsu sieciowego.

(config-if)# ip address adres-IP

Przypisuje adres IP do konfigurowanego interfejsu sieciowego.

(config-if)# vnet trunk [list nazwa-EVN]

Przypisuje konfigurowany interfejs sieciowy do wszystkich skonfigurowanych instancji EVN. Pod-komenda [list] zawęża zasięg funkcji EVN do jednej określonej w komendzie instancji.

(config-if)# vnet name nazwa-EVN

Przechodzi do trybu konfiguracji określonej instancji EVN.

(config-if-vnet)# ip address adres-IP

Przypisuje adres IP do konfigurowanej instancji EVN.

Komendy SHOW

# show vrf

Wyświetla wszystkie instancje VRF, skonfigurowane na danym urządzeniu.

# show vrf detail

Wyświetla szczegółowe informacje na temat wszystkich instancji VRF, skonfigurowanych na danym urządzeniu.

# show running-config | section vrf

Wyświetla konfigurację funkcji VRF.

# show [running-config / derived-config]

Wyświetla bieżącą konfigurację urządzenia bądź pełną bieżącą konfigurację wraz z domyślnie ukrytymi komendami funkcji EVN. Jako że funkcja EVN stanowi jedynie uproszczenie konfiguracji VRF-Lite, wykonanie komendy [vnet trunk] pociąga za sobą wiele ukrytych przed administratorem komend CLI, wykonywanych względem utworzonych przez funkcję EVN pod-interfejsów. Komenda [show derived-config] wyświetla pełną konfigurację wraz z utworzonymi pod-interfejsami.

Pozostałe tematy związane z funkcją VRF, EVN

PDFPRINT

Robert T Kucharski

Cisco Network Engineer in GPW.

Dodaj komentarz