(KP) NAT Dynamic High Availability**

Połączenie do dwóch dostawców ISP (Dynamic NAT)

Konfiguracja interfejsów

(config)# interface interfejs(LAN)

Przechodzi do poziomu konfiguracji interfejsu znajdującego się wewnątrz sieci LAN.

(config-if)# ip nat inside

Określa konfigurowany interfejs, jako interfejs wewnętrzny względem, translacji NAT.

(config-if)# interface interfejs(WAN-1)

Przechodzi do poziomu konfiguracji pierwszego interfejsu zewnętrznego.

(config-if)# ip nat outside

Określa konfigurowany interfejs, jako pierwszy interfejs zewnętrzny, względem translacji NAT.

(config-if)# interface interfejs(WAN-2)

Przechodzi do poziomu konfiguracji drugiego interfejsu zewnętrznego.

(config-if)# ip nat outside

Określa konfigurowany interfejs, jako drugi interfejs zewnętrzny, względem translacji NAT.

Konfiguracja listy ACL

Aby określić jakie wewnętrzne adresy IP (Inside local IP address) mogą uczestniczyć w translacji NAT, należy stworzyć listę ACL.

Konfiguracja Access Listy została opisana w artykule: Konfiguracja listy ACL.

(config)# ip access-list {extend / standard} nazwa-ACL

Tworzy nową listę named ACL.

(config-ext-nacl)# {permit / deny} protokół(IP, UDP, TCP, ICMP, GRE, ESP, AHP czy OSPF) {any / host źródłowy-adres-IP / źródłowy-adres-IP dzika-maska} źródłowy-port {any / host docelowy-adres-IP / docelowy-adres-IP dzika-maska} docelowy-port [log / log-input]

Dodaje nowy wpis do konfigurowanej listy named ACL, z numerem sekwencyjnym większym o 10. Poniższe wartości odnoszą się do zakresu portów protokołu UDP bądź TCP:
* eq =równy.
* ne nie równy.
* it < mniejszy od.
* gt > większy od.
* range range:x to yzakres od x do y.

# show ip access-list [ACL]

Wyświetla konfigurację wskazanej listy / wszystkich skonfigurowanych list ACL.

Konfiguracja ruter mapy

Konfiguracja Router Mapy została opisana w artykule: Router Map.

(config)# route-map nazwa-1 permit sequence

Tworzy router mapę względem pierwszego interfejsu zewnętrznego WAN.

(config-route-map)# match ip address nazwa-ACL

Przypisuje do konfigurowanej router mapy, adresy IP które będą tłumaczone przez translację PAT.

(config-route-map)# match interface interfejs-1

Przypisuje do konfigurowanej router mapy, pierwszy interfejs sieciowy WAN-owy.

(config-route-map)# route-map nazwa-2 permit sequence

Tworzy router mapę względem drugiego interfejsu zewnętrznego WAN.

(config-route-map)# match ip address nazwa-ACL

Przypisuje do konfigurowanej router mapy, adresy IP które będą tłumaczone przez translację PAT.

(config-route-map)# match interface interfejs-2

Przypisuje do konfigurowanej router mapy, drugi interfejs sieciowy WAN-owy.

# show route-map [nazwa-router-mapy]

Wyświetla określoną / wszystkie skonfigurowane na danym urządzeniu Router Mapy.

Konfiguracja puli zewnętrznych adresów IP

(config)# ip nat pool nazwa-puli-1 startowy-adres-IP-1 końcowy-adres-IP-1 {netmask maska / prefix-length prefix}

Tworzy pulę publicznych adresów IP (Inside global IP address). Maska określa sieć do jakiej należą wskazane adresy IP.

(config)# ip nat pool nazwa-puli-2 startowy-adres-IP-2 końcowy-adres-IP-2 {netmask maska / prefix-length prefix}

Tworzy pulę publicznych adresów IP (Inside global IP address). Maska określa sieć do jakiej należą wskazane adresy IP.

# show running-config | section pool

Wyświetla konfigurację puli publicznych adresów IP (Inside global IP address) .

Konfiguracja dynamicznej translacji NAT

(config)# ip nat inside source route-map nazwa-1 pool nazwa-puli-1

Przypisuje pierwszą router mapę, określającą wewnętrzne adresy IP (Inside local IP address) do translacji PAT, względem pierwszej puli adresów zewnętrznych WAN.

(config)# ip nat inside source route-map nazwa-2 pool nazwa-puli-2

Przypisuje drugą router mapę, określającą wewnętrzne adresy IP (Inside local IP address) do translacji PAT, względem drugiej puli adresów zewnętrznych WAN.

(config)# ip route 0.0.0.0 0.0.0.0 {interfejs-1 10(1)(AD) / adres-IP 10(1)(AD))

Dodaje pierwszy statyczny wpis, względem pierwszego interfejsu sieciowego WAN do tablicy routingu z wartością dystansu administracyjnego (AD) wynoszącą 10.

(config)# ip route 0.0.0.0 0.0.0.0 {interfejs-2 20(1)(AD) / adres-IP 20(1)(AD)}

Dodaje pierwszy statyczny wpis, względem pierwszego interfejsu sieciowego WAN do tablicy routingu z wartością dystansu administracyjnego (AD) wynoszącą 20.

# show running-config | section nat inside

Wyświetla konfigurację protokołu NAT.

Komendy Show, Clear oraz Debug

Komendy Show

# show ip nat translations

Wyświetla listę przeprowadzonych translacji NAT oraz PAT.

# show ip nat statistics

Wyświetla statystyki protokołu NAT oraz PAT.

Komendy Clear

# clear ip nat statistics

Czyści wszystkie zapisane statystyki protokołu NAT oraz PAT.

# clear ip nat translations*

Czyści wszystkie zapisane statystyki translacji protokołu NAT oraz PAT.
Przypadku usuwania konfiguracji protokołu PAT, wpierw należy użyć komendę [clear ip nat translations *].

Komendy Debug

# debug ip nat

Rozpoczyna debugowanie zdarzeń protokołu NAT oraz PAT.

# debug ip icmp

Rozpoczyna debugowanie zdarzeń protokołu ICMP, dzięki czemu możemy zobaczyć z jakiego adresu IP nadchodzą wysyłane wiadomości ICMP, a tym samym potwierdzić czy translacja NAT doszła do skutku.

Pozostałe tematy związane z protokołem NAT

NATv6

PDFPRINT

Robert T Kucharski

Cisco Network Engineer in GPW.

Dodaj komentarz